End User Monitoring (EUM)

cancel
Showing results for 
Search instead for 
Did you mean: 

Network Reqest Naming - Regex

Highlighted
Explorer

I'm having difficulty setting up network request naming using regex and can't find documentation on how these regex should be escaped, what portion of the URL they apply to etc and can't get it to work as I expect it should.

 

Given a network request URL such as: https://foo.bar.com/api/member/12345/profile I want to name it without the 12345, so in the regex field I enter /api/member/\d+/profile and name the request using "Full domain, segments 1,2,4 of the URL" as attached image shows.

 

However, in the network requests, I still see every individual URL with the member id, so this uses up the 500 network requests very quickly.

 

I've tried escaping this regex in various ways, but can't get it to work. What should I enter into the regex field to name this URL correctly?

 

Screen Shot 2018-05-01 at 7.57.38 am.png

Network Reqest Naming - Regex
5 REPLIES 5
Highlighted
AppDynamics Team

Hi Wabz,

 

You can use something like below in order to escape capturing numbers in your URLS: 

 

/[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\

 

For better help, you can test out your matching regex options and results against your page URLS here: 

https://docs.appdynamics.com/display/PRO44/Using+Regular+Expressions

http://myregexp.com/

 

And add them in rules accordingly. Hope this helps.

 

Thanks,

Chitra



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted
Explorer

Hi,

 

Sorry if I wasn't clear, but that's not what I'm asking, I don't want to capture numbers (your example regex doesn't even appear to do that properly). I couldn't find documentation on what part of the URL needs to be matched (e.g. is the protocol included?), or what kinds of characters need to be escaped (it seems like '/' does need to be). The documentation linked seems to apply to Agents only?

 

However, I got this working using (it seems like there's no subsequence matching, and you need to escape "/"):

 

https:.*\/api\/member/\d+\/profile

 

However, I can't make this work for network requests that don't have load - i.e. if I uncheck "Only Show Requests With Load", I see a lot of requests that look like they should match the regex, but also show "0" in the Total Requests column and "0" in the "Requests Per Minute" column. I have just deleted all 500 requests, and these show up very quickly, so they're not old requests or anything like that. What might I be missing here?

 

Also, what exactly does it mean when a network request doesn't have load?

 

Thanks!

Highlighted
AppDynamics Team

Hi Wabz,

 

Ideally all these dashboards show only those requests which are seeing load in the selected time frame. But when you uncheck the "with load" option, the resultant list will show you all your requests which ever got registered; including those pages which do not have load currently(means whic are not being accessed in that time frame). Say you selected last 5 minutes or last 15 minutes so then this list will show you all the requests which have load as wellas those whichdo not have load right now.

 

Obviously naming convention won't take affect on those inactive pages, it will be visible only on the pages which have load. Also you need to delete all those already registered requests from that screen and let them re-register with new naming rules. Unless you delete the older pages new naming rule will not take effect.

 

Hope that clarifies. Do let u sknow in case you have questions. 

 

Thank You,

Chitra



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted
Explorer

Thanks, that clarifies things, but I'm still not sure why they're showing up. Here are the steps I'm doing:

 

1) Uncheck "Only Show Requests With Load". "500 of 500" results show up

2) Select *all* requests, and delete them all. "0 of 0" results show up. So far, so good.

3) Within a minute, many requests show up with 0 Total Requests (I'm showing requests for the last hour), and get filtered out if I select "Only Show Requests With Load". This happens days after I've applied a rule that should name these requests too (they don't get named).

 

This seems like a bug to me, there doesn't appear to be a way for me to stop these requests filling up the 500 limit. Any help appreciated.

Highlighted
AppDynamics Team

Hi Wabz,

 

Yes we have this limit of 500 pages(a limit of 500 total base pages (including virtual pages) + iframes) and 500 Ajax registration; Once this is reached no new pages will be registered(under any new name) until you delete the unwanted requests and bring your requests below limit. So you need to check whichever is(or if both are) exceeding, and you'll have to delete the requests which do not have load now or are unwanted.

 

 

If they are returning back that means they are still being reported under older names somehow(probably becuase your page naming is not taking effect properly).

 

 

For better controlling this scenario we suggest that you groupsimilar URLs into 1 using the custom page naming option as mentione din the doc link below:
https://docs.appdynamics.com/display/PRO44/Configure+Page+Identification+and+Naming

 

 

Thanks,

Chitra



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.