EUM and Analytics (Mobile, Metrics)

cancel
Showing results for 
Search instead for 
Did you mean: 

Appdynamics not working with latest Xamarin

Appdynamics not working with latest Xamarin

Device Information :

 

=== Visual Studio Community 2017 for Mac ===

Version 7.1 (build 1297)
Installation UUID: 0234f465-39d6-4e97-a770-24bfa6b447ef
Runtime:
    Mono 5.2.0.215 (d15-3/da80840) (64-bit)
    GTK+ 2.24.23 (Raleigh theme)

    Package version: 502000215

=== NuGet ===

Version: 4.3.0.2418

=== .NET Core ===

Runtime: Not installed
SDK: Not installed
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.2.0/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.5.5
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 8.3.3 (12175.1)
Build 8E3004b

=== Xamarin.iOS ===

Version: 10.12.0.20 (Visual Studio Community)
Hash: 80b8487d
Branch: d15-3
Build date: 2017-08-18 16:07:26-0400

=== Xamarin.Android ===

Not Installed

=== Xamarin.Mac ===

Version: 3.6.0.19 (Visual Studio Community)

=== Xamarin Inspector ===

Version: 1.2.2
Hash: b71b035
Branch: d15-1
Build date: Fri, 21 Apr 2017 17:57:12 GMT

=== Build Information ===

Release ID: 701001297
Git revision: 9c5299666538b2f8baf501418a5c064d784d64da
Build date: 2017-08-07 11:29:35-04
Xamarin addins: 3bb0c32a14f1b7e368bf5ac53a84c3581c019391
Build lane: monodevelop-lion-d15-3

=== Operating System ===

Mac OS X 10.12.6
Darwin 16.7.0 Darwin Kernel Version 16.7.0
    Thu Jun 15 17:36:27 PDT 2017
    root:xnu-3789.70.16~2/RELEASE_X86_64 x86_64
=================================================

We have used following code in Xamarin but it is not working

var config =  AgentConfiguration.Create("<UEM_APP_KEY>");
            AppDynamics.Agent.Instrumentation.InitWithConfiguration(config);

Please help me to find out any solution in Xamarin integration.

Appdynamics not working with latest Xamarin
1 REPLY
Employee

Re: Appdynamics not working with latest Xamarin

Hi Kuntal,

 

Can you please let us know the exact version of xamarin agent in use?

Let us know what error you are seeing. Attach logs. 

Also change 

var config =  AgentConfiguration.Create("<UEM_APP_KEY>");

to

var config = AppDynamics.Agent.AgentConfiguration.Create("<UEM_APP_KEY>");

 

Regards,

Gaurav Soni