Dynamic Languages (Node.JS, Python, PHP, C/C++, Webserver Agent)

cancel
Showing results for 
Search instead for 
Did you mean: 

appdynamics module for npm contains high security issues

appdynamics module for npm contains high security issues

Aqua scan reports base image high issue.

CVE-2018-1000620

 

appdynamics@4.5.12 package is installed from the public npm registry.

/ # npm ls cryptiles
/
`-- appdynamics@4.5.12
`-- appdynamics-libagent@4.5.12
`-- request@2.83.0
`-- hawk@6.0.2
`-- cryptiles@3.1.4

 

Please advise when version would be fixed.

Tags (1)
appdynamics module for npm contains high security issues
3 REPLIES 3
Highlighted
AppDynamics Team

Re: appdynamics module for npm contains high security issues

Hey Slawomir,

 

This has been resolved in 4.5.13, which I anticipate will be available in a few weeks.

 

Regards,

Kyle

Thanks,
Kyle Furlong, Technical Lead (C++ and Dynamic Languages)




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.

Re: appdynamics module for npm contains high security issues

Thank you for taking care and plan to solve this issue.

When 4.5.13 will be released?

I see the latest available version as 4.5.12: https://www.npmjs.com/package/appdynamics

 

Thanks, Slawek

AppDynamics Team

Re: appdynamics module for npm contains high security issues

Hi Slawek,

 

Unfortunetly we don't have exact timelines. But as Kyle mentioned, we anticipate that it will be realeased in few weeks. Generally, we have a release cycle in every two/three weeks.

 

Thanks

Abhimanyu



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.