Dynamic Languages (Node.JS, Python, PHP, C/C++, Webserver Agent)

cancel
Showing results for 
Search instead for 
Did you mean: 

Pip Module MacOSX Python 3.x

Highlighted
New Poster

I can't seem to install the Python pip module....

 

I can see the pip modules listed ...

 

$ pip3 search appdynamics
appdynamics (4.5.0.0)                            - Python agent for AppDynamics
appdynamics-bindeps-linux-x64 (7.0)              - Dependencies for AppDynamics Python agent
appdynamics-bindeps-linux-x86 (7.0)              - Dependencies for AppDynamics Python agent
appdynamics-bindeps-osx-x64 (7.0)                - Dependencies for AppDynamics Python agent
appdynamics-proxysupport-linux-x64 (1.8.0.51.1)  - Proxysupport for AppDynamics Python agent
appdynamics-proxysupport-linux-x86 (1.8.0.51.1)  - Proxysupport for AppDynamics Python agent
appdynamics-proxysupport-osx-x64 (1.8.0.51.1)    - Proxysupport for AppDynamics Python agent
AppDynamicsDownloader (0.2.2)                    - AppDynamics Download Robot
AppDynamicsREST (0.4.10)                         - AppDynamics REST API Library

I attempted to install the modules with ...

 

$ pip3 install appdynamics-bindeps-osx-x64 appdynamics-proxysupport-osx-x64
Collecting appdynamics-bindeps-osx-x64
  

I got the following error ...

 

Could not find a version that satisfies the requirement appdynamics-bindeps-osx-x64 (from versions: )
No matching distribution found for appdynamics-bindeps-osx-x64

So what am I missing ?

Pip Module MacOSX Python 3.x
4 REPLIES 4
Highlighted
AppDynamics Team

Hi Seth,

 

Can you please try the following command and let us know the output

 

pip3 install -U appdynamics==4.5.0.0

 

Thanks,

Sajna Sreenivasan



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted
AppDynamics Team

Hi Seth,

 

You can install python appd agent by jsut doing

pip3 install appdynamics

which pulls you latest v4.5.0 appd python agent.

 

After Installation:

You might also need to configure python agent. Click on the link for details: https://docs.appdynamics.com/display/PRO45/Install+the+Python+Agent



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Tags (2)
Highlighted
New Poster

The below is what I get when doing a pip3 install with and without version ....

 

$ pip3 install -U appdynamics==4.5.0.0
Collecting appdynamics==4.5.0.0
  Using cached https://files.pythonhosted.org/packages/cb/d4/71572337a4f797fab3dfc07ebab867ec0996817070a0859e63335e5c5d39/appdynamics-4.5.0.0-py2.py3-none-any.whl
Collecting appdynamics-proxysupport-osx-x64==1.8.0.51.1; sys_platform == "darwin" and (platform_machine == "x86_64" or platform_machine == "AMD64") (from appdynamics==4.5.0.0)
  Using cached https://files.pythonhosted.org/packages/5d/26/6bf794ce7380a459ef05df9e3dd40c399dae17f9f6b6fc93d44db9ba07d2/appdynamics_proxysupport_osx_x64-1.8.0.51.1-py2.py3-none-any.whl
Collecting appdynamics-bindeps-osx-x64==7.0; sys_platform == "darwin" and (platform_machine == "x86_64" or platform_machine == "AMD64") (from appdynamics==4.5.0.0)
  Could not find a version that satisfies the requirement appdynamics-bindeps-osx-x64==7.0; sys_platform == "darwin" and (platform_machine == "x86_64" or platform_machine == "AMD64") (from appdynamics==4.5.0.0) (from versions: )
No matching distribution found for appdynamics-bindeps-osx-x64==7.0; sys_platform == "darwin" and (platform_machine == "x86_64" or platform_machine == "AMD64") (from appdynamics==4.5.0.0)
Highlighted
New Poster

looks like it only works in Python 2.x .... 

 

$ pip install appdynamics
... Successfully installed appdynamics-4.5.0.0 appdynamics-bindeps-osx-x64-7.0 appdynamics-proxysupport-osx-x64-1.8.0.51.1
$ python --version
Python 2.7.15