Dynamic Languages (Node.JS, Python, PHP, C/C++, Webserver Agent)

cancel
Showing results for 
Search instead for 
Did you mean: 

PHP segfault

SOLVED
Highlighted

PHP segfault

Hi All!

 

We are facing with an issue using the PHP agent on our application.

 

After we installed the agent we are getting Segmentation fault (11) errors. After we disabled the agent this error did not occure again.

 

Has anyone seen similar before? Is there any fix for this?

 

This is the error message:

 

[Sat Feb 02 08:57:49.488042 2019] [core:notice] [pid 2053] AH00051: child pid 16769 exit signal Segmentation fault (11), possible coredump in /etc/apache2
[Sat Feb 02 08:57:53.491981 2019] [core:notice] [pid 2053] AH00051: child pid 2220 exit signal Segmentation fault (11), possible coredump in /etc/apache2
[Sat Feb 02 08:57:57.495323 2019] [core:notice] [pid 2053] AH00051: child pid 2117 exit signal Segmentation fault (11), possible coredump in /etc/apache2
[Sat Feb 02 08:57:57.495453 2019] [core:notice] [pid 2053] AH00051: child pid 25962 exit signal Segmentation fault (11), possible coredump in /etc/apache2
[Sat Feb 02 08:58:03.499494 2019] [core:notice] [pid 2053] AH00051: child pid 2286 exit signal Segmentation fault (11), possible coredump in /etc/apache2
[Sat Feb 02 08:58:08.503125 2019] [core:notice] [pid 2053] AH00051: child pid 2092 exit signal Segmentation fault (11), possible coredump in /etc/apache2
[Sat Feb 02 08:58:08.503232 2019] [core:notice] [pid 2053] AH00051: child pid 2276 exit signal Segmentation fault (11), possible coredump in /etc/apache2

The information about the system:

Appdynamics version: AppDynamics Controller build 4.5.5.10390
kernel: Linux eu2 3.13.0-53-generic #89-Ubuntu SMP Wed May 20 10:34:39 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux OS: Ubuntu 14.04.5 LTS apache: Server version: Apache/2.4.7 (Ubuntu) Server built: Jul 15 2016 15:34:04 php: PHP 5.5.9-1ubuntu4.22 (cli) (built: Aug 4 2017 19:40:28) Copyright (c) 1997-2014 The PHP Group Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies with the ionCube PHP Loader + Intrusion Protection from ioncube24.com (disabled) v5.0.7, Copyright (c) 2002-2015, by ionCube Ltd. with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies
Tags (2)
PHP segfault
3 REPLIES 3
Employee

Re: PHP segfault

Hi Sandor,

 

Unfortunately we don't yet support the ionCube loader module. I suspect these crashes are due to that module being used, as we've experienced in the past.

Thanks,
Kyle Furlong, Technical Lead (C++ and Dynamic Languages)




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.

Re: PHP segfault

Hi Kyle,

 

Got it, thank you.

So, you have already seen this issue with IonCube, but this is not supported at the moment. Is that correct? So, this is kind of extected behavior or known issue.

 

Is there any hint when will be this supported?

 

Best,

Sandor

Employee

Re: PHP segfault

Hi Sandor,

 

Yes, this is expected with ionCube loader. I don't yet have a timeline for this support.

 

 

Thanks,
Kyle Furlong, Technical Lead (C++ and Dynamic Languages)




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.