Dynamic Languages (Node.JS, Python, PHP, C/C++, Webserver Agent)

cancel
Showing results for 
Search instead for 
Did you mean: 

PHP agent not connecting to the controller

Highlighted
New Poster

PHP agent not connecting to the controller

I'm starting trial for APM product.

 

I try to install PHP agent on ubuntu server with nginx web server.

First, I tried to use the wizards step. Install steps not throwing an error, but it didn't connect to the controller.

Then, I used https://docs.appdynamics.com/display/PRO43/Install+the+PHP+Agent to install agent manually.

Again, it didn't throw any error, but it didn't connect to the controller.

At this step, I checked the logs, and it output something like this : 

 

2017-12-11 09:15:01.094 UTC INFO 31304 [agent.AgentKernel] starting up agent kernel [4.3.7.0GA.13218.574dfc04d2aa143c9a690628bc2$
2017-12-11 09:15:01.095 UTC INFO mynode 31304 [config.ConfigChannel] sending config request with version -1
2017-12-11 09:15:02.096 UTC ERROR mynode 31304 [config.ConfigChannel] could not send config request
2017-12-11 09:19:34.676 UTC INFO mynode 31303 [config.ConfigChannel] sending config request with version -1
2017-12-11 09:19:34.864 UTC INFO mynode 31303 [agent.ZMQControlTransport] received start node response, size: 9 bytes
2017-12-11 09:19:34.866 UTC ERROR mynode 31303 [config.ConfigChannel] could not send config request
2017-12-11 09:37:01.478 UTC INFO mynode 31304 [config.ConfigChannel] sending config request with version -1
2017-12-11 09:37:01.559 UTC INFO mynode 31304 [agent.ZMQControlTransport] received start node response, size: 45 bytes
2017-12-11 09:37:01.561 UTC ERROR mynode 31304 [config.ConfigChannel] could not send config request
2017-12-11 09:37:39.245 UTC INFO mynode 31303 [config.ConfigChannel] sending config request with version -1
2017-12-11 09:37:39.247 UTC ERROR mynode 31303 [config.ConfigChannel] could not send config request
2017-12-11 09:37:55.437 UTC INFO mynode 31304 [config.ConfigChannel] sending config request with version -1
2017-12-11 09:37:55.440 UTC ERROR mynode 31304 [config.ConfigChannel] could not send config request

 

I tried to resolve it using steps described here : https://docs.appdynamics.com/display/PRO43/Resolve+PHP+Agent+Installation+Issues

 

But when I run "php -i | less", I didn't see any appdynamic block within it.

I have checked that there is appdynamics_agent.ini in the same directory with php.ini

Is there any solution about it?

 

Thank you in advance

Tags (2)
PHP agent not connecting to the controller
4 REPLIES
Employee

Re: PHP agent not connecting to the controller

Hi Destiya,

 

Could you please verify the system as per the troubleshooting details mentioned at https://community.appdynamics.com/t5/Knowledge-Base/PHP-Agent-installation-troubleshooting-guide/ta-...

 

Best Regards,

Piyush

New Poster

Re: PHP agent not connecting to the controller

Hi Piyush,

 

Thank you for your help.

It seems I need to place the configuration within the additional configuration directory to make it work.

 

Next, how can I run the agent for both PHP FPM and CLI.

Do I need to install it twice and place the configuration in both FPM and CLI?

Because they have different configuration folder.

 

THank you again.

Employee

Re: PHP agent not connecting to the controller

 Hi Destiya,

 

One single agent installation can serve all of these modes but it needs to switch to the manual start of JAVA proxy process and some more tweaking in the configs. For simplicity and easy access to agent files, I suggest going ahead with multiple installation directories using -i and -e parameters mentioned at https://docs.appdynamics.com/display/PRO43/Install+the+PHP+Agent+by+Shell+Script

 

Best Regards,

Piyush

Discoverer

Re: PHP agent not connecting to the controller

Hi Destiya,

 

I have the same issue. Is it fix ?

 

Regards,

Michael