Dashboards

cancel
Showing results for 
Search instead for 
Did you mean: 

When there is no data for a metric, it is not allowing me to use that in the expression

New Member

When there is no data for a metric, it is not allowing me to use that in the expression

Hi,

I am trying to create a dashboard to show the availability of a service. To get this, im picking the calls per min and errors per min metric. But since there are no errors, errors per min graph is showing as no data. But when I use it in an expression: ({calls} - ({errors} + 0)) * 100 / ({calls} + 1), though the calls is not 0, it still shows the graph as unavailable. 

Is there a way to set a static value when there is no data? Since in this case, the availability should be 100%, since there are no errors and we have calls. 

Tags (1)
When there is no data for a metric, it is not allowing me to use that in the expression
3 REPLIES 3
Architect

Re: When there is no data for a metric, it is not allowing me to use that in the expression

Hi Ajay

 

Please log a request to AppD Support, there is a feature flag they can set that resolves this problem, to ignore the empty values for the calculation to work correctly.

 

Ciao



Learn more about me in the Community Member Spotlight Q & A
New Member

Re: When there is no data for a metric, it is not allowing me to use that in the expression

Thank you! Will open a support case for this

AppDynamics Team

Re: When there is no data for a metric, it is not allowing me to use that in the expression

Hello Ajay,

 

As there are no errors the error per minute shows "no data available" (imagine this as null) so when you perform any operation on null you will get null value.

 

This issue can be resolved by setting the com.appdynamics.metric.query.metricexpressions.tolerateNull flag to true in ControllerFlagServlet. If you are using a SaaS controller please reach out to AppDynamics support to enable this flag.

 

If you are using On-Prem Controller follow the below steps to enable the flag:

1. Login to <controllerURL>/controller/

2. Use root@system and controller root password for login

3. Look for metricexpressions.tolerateNull field and set it to ‘true’

4. Hit Submit button.