Dashboards

cancel
Showing results for 
Search instead for 
Did you mean: 

Multiple Iframes widgets cause weird behavior

SOLVED
Builder

Multiple Iframes widgets cause weird behavior

Hi Team,

 

I have a dashboard which hosts 5 Iframe widgets and the URLs working in the background provides the status of some probes from a third party system. The problem I am facing with the dashboard is, "The output of the probes are getting mixed with each other in the widgets". The example is given below:

 

Iframe Widget Name: Probe 1 (URL = http://abc.com/probe1)

Output:

Status: OK

probe1.server1=ok

probe1.server2=ok

***************************************

 

Iframe Widget Name: Probe 2 (URL = http://abc.com/probe2)

Output:

Status: OK

probe2.server1=ok

probe2.server3=ok

probe2.server5=ok

***************************************

 

Iframe Widget Name: Probe 3 (URL = http://abc.com/probe3)

Output:

Status: OK

probe3.server1=ok

probe3.server2=ok

***************************************

 

and so on....

But the actual result which I am getting in the dashboard is a random mix of the results:

Example:

 

Iframe Widget Name: Probe 1 (URL = http://abc.com/probe1)

Output:

Status: OK

probe1.server1=ok

probe2.server2=ok

probe3.server2=ok

***************************************

 

Iframe Widget Name: Probe 2 (URL = http://abc.com/probe2)

Output:

Status: OK

probe2.server1=ok

probe3.server1=ok

probe3.server2=ok

***************************************

 

Iframe Widget Name: Probe 3 (URL = http://abc.com/probe3)

Output:

Status: OK

probe1.server1=ok

probe3.server2=ok

***************************************

 

and so on....

 

In order to test this behavior, I have checked these 5 URLs in 5 different tabs of a browser but they work without any issues. 

 

Want to check if anyone has faced such problem, Any help is appreciated. I have attached a document capturing the output of Individual Iframe and the combined output when put together. 

 

Regards,

Mukesh Singh

 

 

 

Multiple Iframes widgets cause weird behavior
10 REPLIES 10
Highlighted
AppDynamics Team

Re: Multiple Iframes widgets cause weird behavior

Hi Mukesh,

 

Can you please share below details-

1. Screenshot of what you are seeing once you hit the url on the browser. Is it different from what you are seeing on the dashboard?

2. Screenshot of the configuration of an iFrame widget.

3. Does it happens only when you create multiple iFrame widget? Can you try with only single widget and let us know how it goes.

 

Thanks,

Yogesh



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Builder

Re: Multiple Iframes widgets cause weird behavior

Hi Yogesh,

Thanks for your response. Please see my response for your questions:

1. Screenshot of expected Iframe widget which should be same as that when executing in a browser is already attached to the original thread.

2. I will send you screenshot of the widget configuration by tomorrow but just to let you know I just have the different target URLs configured for different widgets.

3. Yes it happens only when I have more than 1 iframe widget on a dashboard. Only single Iframe widget each on different dashboards works fine.

Regards,
Mukesh Singh
Builder

Re: Multiple Iframes widgets cause weird behavior

Hi Yogesh,

 

As mentioned earlier, please find the screenshot of Iframe widget configurations and their result in browser.

 

Please note that the widgets work fine when we click on their configuration, they load accurate result which is same as that of browser.  The moment we exit edit mode and put the dashboard to live mode, they start behaving weirdly.

 

 

Regards,

Mukesh Singh

 

AppDynamics Team

Re: Multiple Iframes widgets cause weird behavior

Hi Mukesh,

 

Please provide below details to check this further.

 

  • Is this a shared dashboard?
  • Can you try to create a new dashboard and then check the behaviour? 
  • Please export the dashboard and share the .json file here.

Thanks,

Yogesh



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Builder

Re: Multiple Iframes widgets cause weird behavior

Hi Yogesh,

 

Please find attached couple of HAR files and JSON of the dashboard. Yes, this is a shared URL and it is reproducible even if I create new dashboard involving Iframe widgets.

 

Note: Please remove the extension (.doc) from each of the files. The reason why I have added this extension is that the community portal doesn't support .har, .zip and .json file extensions.

 

Regards,

Mukesh Singh

AppDynamics Team

Re: Multiple Iframes widgets cause weird behavior

Hi Mukesh,

 

Can you please confirm if the url which you have configured in the iFrame widget does not dynamically changes. If it changes, then it should be expected. Let us know if we can have a screen sharing session to discuss this further.

 

Thanks,

Yogesh



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Builder

Re: Multiple Iframes widgets cause weird behavior

Hi Yogesh,

The URL doesn't change dynamically, I confirm that. It would be great if
we can have screen sharing tomorrow anytime as per your convenience.

Regards,
Mukesh Singh


AppDynamics Team

Re: Multiple Iframes widgets cause weird behavior

Hi Mukesh,

 

Can we have a webex meeting tomorrow? Please let me know your few of the available time slots with the time zone to check the issue further.

 

Thanks,

Yogesh



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Builder

Re: Multiple Iframes widgets cause weird behavior

Hi Yogesh,

I will be in the office between 9:00 am to 3:00 pm, IST. Request you to
kindly let me know your availability so that I can make myself free for it.

Regards,
Mukesh Singh