Dashboards

cancel
Showing results for 
Search instead for 
Did you mean: 

Metric browser on dashboards

SOLVED
Highlighted
Producer

Metric browser on dashboards

Hi Team

 

I am trying to load a custom metrics onto the dashboard & it wouldnt load any data.

The custom metrics is from MQ monitoring extension which we have installed for 3 servers & the metrics populates fine in the metric browser but when added into a widget on a dashboard - does not load.

 

I have attached the screenshots.

Kindly suggest on how to get this fixed.

 

Controller - 4.3.8 version

 

Regards

Anjana

 

Metric browser on dashboards
8 REPLIES
Community Manager

Re: Metric browser on dashboards

Hi @Anjana.Mohan

 

Sorry to hear that you have issues loading custom metrics on the dashboard. 

 

Have you searched for similar issues and solutions or knowledgebase articles posted on the Community? Here are our recommendations:

 

 

Please see if one of those clarifies your question. If not, please let us know by updating the thread. 

 

We would also encourage the community members that faced similar issues to assist in resolving this particular case.

 

 


Thanks,
Radhika P




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Employee

Re: Metric browser on dashboards

Hi Anjana,

I suspect that the problem relates to the metric path.

In the Custom Dashboard, I suspect that you need to specify the "Custom" category, and specify the metric path as "Application Infrastructure Performance|<Tier>|Custom Metrics|...".

The screenshot shows the metric path specified in "Servers", with "Root", which I'm pretty sure doesn't match the path to this custom metric in the Metric Browser.

 

Regards,

Brian Wheeldon, Solution Engineer, NYC







Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Producer

Re: Metric browser on dashboards

Hi Brian

 

I copied the path from metric browser itself - see attached.

 

I provided this link in the "Specify a Relative Metric Path:" option.

 

Regards

Anjana

Employee

Re: Metric browser on dashboards

My advice to try the "Custom" metric category (rather than "Servers") remains unchanged.

 

Regards,

Brian Wheeldon, Solution Engineer, NYC







Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Employee

Re: Metric browser on dashboards

A colleague let me know that they ran into the same issue and resolved it by removing the first two segments of the custom path.

Can you also try that and report your results?

 

Thanks,

 

Brian Wheeldon, Solution Engineer, NYC







Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Producer

Re: Metric browser on dashboards

Hi Brian

 

Thank you for your reply.

The first solution doesnt work because the custom metric is not for any application but an individual server which has machine agent(with an extension) & just reporting to the account. So i have to use server option since the agent is not part of any application.

 

Second one - worked but is not very consistent on dashboard & doesnt show any result at all.But before you save, it displays the metrics. I am not sure if we can consistently show case anything from custom metrics.

 

Regards

Anjana

Community Manager

Re: Metric browser on dashboards

Hi @Anjana.Mohan

 

Have you tried removing Application Infrastructure Performance|Root| from the metric path?  Copying the path from the Metric browser and pasting it in the widget will have this extra data. 

 

Let us know how it goes.


Thanks,
Radhika P




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Producer

Re: Metric browser on dashboards

Hi @Brian.Wheeldon

 

The solution worked as per your inputs. Thank you :)

 

@Radhika.Puthiyetath yes , i tried & it works but it takes time to load most of the time due to performance. otherwise it is okay.

 

Thank you so much.

 

Regards

Anjana