cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

Controller (SaaS, On Premises)

Link to the Health Rule Violation inside the email notification directs me to http controller url instead of https

SOLVED
Emrul.Yousof
Creator

Link to the Health Rule Violation inside the email notification directs me to http controller url instead of https

Hello,

 

For an On-Prem Controller, the email notification contains the link to the Events but when I click on the link it gets an error ie. "(controller_name.domain) didn't send any data/ ERR_EMPTY_RESPONSE". This is due to the link in the notification is directing to url which is http but our controller is ssl enabled and the url has https.

 

From where can I fix the link to the controller so that the link to the controller events can have https connection ?

 

Thanks,

Emrul Yousof

By replying you agree to the Terms and Conditions of the AppDynamics Community.
Link to the Health Rule Violation inside the email notification directs me to http controller url instead of https
1 REPLY 1
Mario.Morelli
Architect

Hi There

 

From my old KB's, you can add the following startup parameter to the Controller

File to update below

<AppD_Cont_Install_DIR>/appserver/glassfish/domains/domain1/config/domain.xml

 

<jvm-options>-Dappdynamics.controller.ui.deeplink.url=http://<controller-host>:<port>/controller</jvm-options>

 

I believe you can possibly add this via the EC as well:)

 

Support should also be able to assist you should this not work anymore



Learn more about me in the Community Member Spotlight Q & A