cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

Controller (SaaS, On Premises)

Kubernetes install

T.Singh
Creator

Kubernetes install

Hi All

Im trying to install on my rke cluster and have read the documentation.

There seem to be no instructions on how to deploy the operator first. After creating a namespace, it jumps straight to 'deploy cluster agent operator yml' without any predefined yml code

I tried the github readme as well, do I need to download the entire deploy directory from github or just the operator yml?

Tags (2)
By replying you agree to the Terms and Conditions of the AppDynamics Community.
Kubernetes install
17 REPLIES 17
T.Singh
Creator

I've found the trial license does not cover Kubernetes agent licensing...which is a bit beside the point.

AppD is aware and discussing internally, unfortunately, no immediate fix. I've been chasing for a week with no luck.

Chris.Edwards
Creator

Yea... I think I found out part of mine though. It does leave me with one question for the team:

 

If my AppDynamics is internally hosted and behind a loadbalancer does that constitute this part of BOTH the proxy and SSL cert? (https://docs.appdynamics.com/display/PRO45/Configure+the+Cluster+Agent#ConfiguretheClusterAgent-Conf...

 

I think this is my issue, and I just wanted to know if the resolution would be to configure a proxy based on my loadbalancer, and then pass kubernetes my SSL cert? @Jeffrey.Holmes @Ondine.Kilker

Jeffrey.Holmes
AppDynamics Team

@Chris.Edwards you would want to configure a cert for the endpoint where the cluster agent ssl connection would terminate, typically with the load balancer. I don't think you'd need the on prem controller cert unless the load balancer to controller connection is using ssl as well.

Chris.Edwards
Creator

Ah okay. The only cert we have is terminated at the loadbalancer level, I saw in the docs that there's an option to add a proxy, but Im not sure if a loadbalancer counts as a proxy or if its technically different.

 

 

Also, now, I'm getting the unauthorized notice

 

agentregistrationmodule.go:113 - Failed to send agent registration request: Status: 401 Unauthorized

 

I have confirmed that I am using the Name and Access Key listed in the Administration Tools > License > Account, but to no avail..

Jeffrey.Holmes
AppDynamics Team

Two thoughts: generally that error indicates an error with access key, so worth double checking the value. Also have you setup the secret based on that value using:

kubectl -n appdynamics create secret generic cluster-agent-secret --from-literal=controller-key=<access-key>

as described on this page:

https://docs.appdynamics.com/display/PRO45/Deploy+the+Cluster+Agent+on+Kubernetes

 

And finally, do you have an available server visibility license?

 

 

Chris.Edwards
Creator

Regarding the access key, I just double checked and everything checks out... Same account name and access key that are on the License > Account tab.

 

And I don't have the server licenses currently set up, Im in the process of getting those from our internal team to use. What type of errors would show if the license wasn't set up? I understand that it wouldn't work, but I want to try and figure out what errors could come from where (for future reference)

Jeffrey.Holmes
AppDynamics Team

You should see a message similar to this for missing server visibility license:

[WARNING]: 2020-06-04 15:23:28 - agentregistrationmodule.go:206 - Agent is not licensed

Chris.Edwards
Creator

Ah, gtocha. I think I found out what my specific issue was. The controller version I was using didn't have the license installed on it yet, I just think that with controllers it doesnt return a licensing error but a different error that's not exactly accurate. But I think that was it