cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

Controller (SaaS, On Premises)

Emails not being sent when From Address is specified

Kevin.Cross
Creator

Emails not being sent when From Address is specified

Hi,

 

We have had a "From Address" specified in our email configuration for some time.

 

Recently I realised that we were no longer receiving emails. I could see alerts being sent and in the actions section it was saying that emails were sent but none were being received.

 

I checked with the administrators of the mail gateway in our company in case they had been put in quarantine but that was not happening.

 

I did a bit of searching and came across this community post which says "The from address field should be empty" so even though we did not have the same issue (having tried with a number of external email addresses) and this contradicts the documentation and our previous experience I tried removing the "From Address" config. Once this was done we started to receive emails.

 

Is there a new issue with configuring the "From Address"? We would like to go back to specifying the "Mail From" address if possible.

 

Regards,

 

Kevin

 

 

Tags (2)
By replying you agree to the Terms and Conditions of the AppDynamics Community.
Emails not being sent when From Address is specified
5 REPLIES 5
Ryan.Paredez
Community Manager

Hi Kevin,

 

We have updated step 3 in the documentation to:

 

  • Default SMTP (SaaS): Leave the From Address field empty, and you will receive emails from the default email address: noreply@<yoursaasprefix>.saas.appdynamics.com
  • Custom SMTP (SaaS): SaaS Controllers on AWS use Amazon Simple Email Service for sending emails. To use a custom domain for the email, you must verify the domain with Amazon SES and then enter your verified email addresses in the From Address field.
  • Default SMTP (On-Premises): Enter your custom email addresses in the From Address field.

 

Do let us know if this helps.


Thanks,
Ryan, AppDynamics Community Manager



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Deepika.Singh
Builder

Hi Ryan,

 

I have tried #1, but it did not send mail from noreply@<yoursaasprefix>.saas.appdynamics.com.

 

 

Ryan.Paredez
Community Manager

Hi @Deepika.Singh,

 

I tried clicking on the document that @Kevin.Cross shared, but it seems like it's being edited right now, so I can't review its contents. When was the last time you were able to view that document?


Thanks,
Ryan, AppDynamics Community Manager



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Deepika.Singh
Builder

hi Ryan,

 

I am facing an issue wrt email configuration. I searched for the community & found this thread.

I have not gone through the document though. Just trying out things based on what users/SMEs are suggesting in these threads.

Tags (1)
Ryan.Paredez
Community Manager

Hi @Deepika.Singh,

 

Can you see if this AppD Docs page helps you out: https://docs.appdynamics.com/display/PRO45/Enable+an+Email+Server

If it does, please do share what you learned back on this post.

 

 


Thanks,
Ryan, AppDynamics Community Manager



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.