cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

Controller (SaaS, On Premises)

Custom Metrics not getting sent to controller

Rajeev.Pokkyarath
New Member

Custom Metrics not getting sent to controller

I'm trying to send some custom metrics to Appdynamics controller. I have a machine agent installed locally under /monitors I created a new directory and added in a shell script and monitor.xml in that directory. The shell script is for testing and I am just echoing "name=Custom Metrics | ZONE1 | WARN, value=1, aggregator=AVERAGE, time-rollup=AVERAGE, cluster-rollup=COLLECTIVE" In the monitor.xml I have made the execution-style to be 'continuous'.

 

The script is in a loop as well.

while true
do
echo "name=Custom Metrics | ZONE1 | WARN, value=1, aggregator=AVERAGE, time-rollup=AVERAGE, cluster-rollup=COLLECTIVE"
sleep 60
done

But I don't see this sent to the Appdynamics controller. Appdynamics doc says "After restarting the Standalone Machine Agent, you should see following message in your log file: Executing script [script]] on the console to make sure your changes work with the machine agent"

I don't see this message when the agent is restarted, nor do I see the script running when I do a ps aux. Any pointers would be helpful. I'm doing a trial for my company and the account I have is a trial version. Not sure if it's a trial restriction?

 

Agent Details:

Using Java Version [1.8.0_162] for Agent Using Agent Version [Machine Agent v4.5.9.2096 GA compatible with 4.4.1.0 Build Date 2019-03-19 19:13:12]

Tags (1)
By replying you agree to the Terms and Conditions of the AppDynamics Community.
Custom Metrics not getting sent to controller
0 REPLIES 0