Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

Controller (SaaS, On Premises)

Connecting AppDynamics SaaS trial version to PostgreSQL


Connecting AppDynamics SaaS trial version to PostgreSQL

I am currently connecting Appdynamics Software as a service trial version with PostgreSQL.


Steps I am following,

  1. I have white-listed the AppD Software as a service Controller IP's for my region in my firewall. 




  1. Then I have downloaded the database agent file "Database Agent for Windows x64 - 64-bit windows (zip)" from


  1. Have configured "controller-info.xml" file with controller-host, controller-port, controller-ssl-enabled, use-encrypted-credentials, account-name, account-access-key values and saved it.


  1. Then to launch the database agent I used the below java command,

java -Xmx1536m -Djava.library.path="C:\Users\RAJA SAHE\Downloads\db-agent-64bit-windows-\auth\x64" -jar "C:\Users\RAJA SAHE\Downloads\db-agent-64bit-windows-\db-agent.jar"


I am facing the below issue,


28 Feb 2020 02:44:34,577 WARN [main] AgentUtil:62 - Possible reasons for unsuccessful agent resolver leading to agent disable: [Controller host info is supposed to be resolved, but found no resolved controller host info]
28 Feb 2020 02:44:34,577 WARN [main] Agent:123 - Could not resolve agent-controller basic configuration


Please assist me to troubleshoot this issue.


I have not configured the credential-store-filename, credential-store-password in the "controller-info.xml" file, Whether this is the rootcause for this issue ?


By replying you agree to the Terms and Conditions of the AppDynamics Community.
Connecting AppDynamics SaaS trial version to PostgreSQL
AppDynamics Team

Hi. Please private message me your configuration file.