cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

Controller (SaaS, On Premises)

Communication in SSLv3/TLS1.0 disabled after 21.4 Saas Controller Update

Communication in SSLv3/TLS1.0 disabled after 21.4 Saas Controller Update

Hello everybody,

 

after the 21.4 update of the Saas controller some of our agents have stopped communicating with the controller due to SSLException attributable to the versions of SSL and TLS used by the applications.


After some support inquiries we discovered that the update has stopped supporting the SSLv3 and TLSv1.0 protocols for security reasons.


The impacted applications run on older environments, but the problem appears to be independent of the agent version and operating systems.
In fact we find the problem on JavaAgent 4.5 both on linux (RHEL7) and on windows (2008 server), while for .Net we see it on windows 2008 both for agent version 4.5 and 21.1.


On the Java side, the common element is that both apps run on Java 1.6, which makes sense, since the agents run with that engine so they have the same problem.

 

While on the .Net side we cannot understand the reason for the communication problems.

 

Is anyone having the same problems?
if so, have you succeeded in solving without update the application environments?

 

Thanks!

Tags (5)
By replying you agree to the Terms and Conditions of the AppDynamics Community.
Communication in SSLv3/TLS1.0 disabled after 21.4 Saas Controller Update