Controller (SaaS, On Premise)

cancel
Showing results for 
Search instead for 
Did you mean: 

Link to the Health Rule Violation inside the email notification directs me to http controller url instead of https

SOLVED
Highlighted
Creator

Link to the Health Rule Violation inside the email notification directs me to http controller url instead of https

Hello,

 

For an On-Prem Controller, the email notification contains the link to the Events but when I click on the link it gets an error ie. "(controller_name.domain) didn't send any data/ ERR_EMPTY_RESPONSE". This is due to the link in the notification is directing to url which is http but our controller is ssl enabled and the url has https.

 

From where can I fix the link to the controller so that the link to the controller events can have https connection ?

 

Thanks,

Emrul Yousof

Link to the Health Rule Violation inside the email notification directs me to http controller url instead of https
1 REPLY 1
Highlighted
Architect

Re: Link to the Health Rule Violation inside the email notification directs me to http controller url instead of https

Hi There

 

From my old KB's, you can add the following startup parameter to the Controller

File to update below

<AppD_Cont_Install_DIR>/appserver/glassfish/domains/domain1/config/domain.xml

 

<jvm-options>-Dappdynamics.controller.ui.deeplink.url=http://<controller-host>:<port>/controller</jvm-options>

 

I believe you can possibly add this via the EC as well:)

 

Support should also be able to assist you should this not work anymore