Controller (SaaS, On Premise)

cancel
Showing results for 
Search instead for 
Did you mean: 

AppD is not getting installed properly

Creator

AppD is not getting installed properly

Hi,

I am trying install AppDynamics as Demo on one Linux VM, it has 2 Core + 4 GB RAM.
Installer is getting stucked at "Verifying the Controller server status..."
After 2 hrs it brings the prompt back saying Installation Finished. But it does not start http listner on 8090.

 

In /opt/appdynamics/controller/.install4j/installation.log, got below errors:

....

....

Please wait while pinging the URL: http://127.0.0.1:43907/controller/rest/serverstatus? Status code: 500
Please wait while pinging the URL: http://127.0.0.1:43907/controller/rest/serverstatus? Status code: 500
Please wait while pinging the URL: http://127.0.0.1:43907/controller/rest/serverstatus? Status code: 500
Please wait while pinging the URL: http://127.0.0.1:43907/controller/rest/serverstatus? Status code: 500
Please wait while pinging the URL: http://127.0.0.1:43907/controller/rest/serverstatus? Status code: 500
Please wait while pinging the URL: http://127.0.0.1:43907/controller/rest/serverstatus? Status code: 500
Please wait while pinging the URL: http://127.0.0.1:43907/controller/rest/serverstatus? Status code: 500
Please wait while pinging the URL: http://127.0.0.1:43907/controller/rest/serverstatus? Status code: 500
Please wait while pinging the URL: http://127.0.0.1:43907/controller/rest/serverstatus? Status code: 500
Please wait while pinging the URL: http://127.0.0.1:43907/controller/rest/serverstatus? Status code: 500
Please wait while pinging the URL: http://127.0.0.1:43907/controller/rest/serverstatus? Status code: 500
Please wait while pinging the URL: http://127.0.0.1:43907/controller/rest/serverstatus? Status code: 500
Timed out waiting for the Controller to start!
Action completed at Thu Jul 13 13:17:24 UTC 2017
[ERROR] com.install4j.runtime.beans.actions.control.RunScriptAction [ID 53625]: Execute action not successful after 2702752 ms
[INFO] com.install4j.runtime.beans.screens.CustomizableProgressScreen [ID 355]: Canceled
cleaning up
Finished


In /opt/appdynamics/controller/logs/server.log, I am getting below logs repeately:
   [#|2017-07-12T06:26:59.052+0000|INFO|glassfish
   4.1|com.appdynamics.licensing.file.LicenseFileReader|_ThreadID=121;_ThreadName=Timer-
   3;_TimeMillis=1499840819052;_LevelValue=800;|Successfully read the license file|#]

   [#|2017-07-12T06:26:59.059+0000|INFO|glassfish
   4.1|com.singularity.ee.controller.beans.license.n|_ThreadID=121;_ThreadName=Timer-
   3;_TimeMillis=1499840819059;_LevelValue=800;|No account found for copying license file to|#]

In /opt/appdynamics/controller/logs/startAS.log, got below logs:
Waiting for domain1 to start ...................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
Command start-domain failed.


Also in /opt/appdynamics/controller/appserver/glassfish/domains/domain1/logs/server.log getting below logs:
   [2017-07-12T06:19:34.912+0000] [glassfish 4.1] [SEVERE] [AS-WEB-GLUE-00167] [javax.enterprise.web._vs.server] [tid: _
   ThreadID=18 _ThreadName=Thread-19] [timeMillis: 1499840374912] [levelValue: 1000] Error adding HttpProbes. NetworkListener
   http-listener-1s GrizzlyProxy is NULL

  [2017-07-12T06:19:34.914+0000] [glassfish 4.1] [SEVERE] [AS-WEB-GLUE-00167] [javax.enterprise.web._vs.server] [tid: _
  ThreadID=18 _ThreadName=Thread-19] [timeMillis: 1499840374914] [levelValue: 1000] Error adding HttpProbes. NetworkListener
  http-listener-2s GrizzlyProxy is NULL

 

Any idea about this issue.

I tried multiple times but still facing this issue. 
Note that this is OpenStack Linux VM.  

I could successfully test on VirtualBox local VM.

Regards

Tags (2)
AppD is not getting installed properly
4 REPLIES 4
Employee

Re: AppD is not getting installed properly

Can you provide below details to assist you on this?

1)Controller/install.log

2)Controller/.install4j/installation.log

3)Controller/logs/server.log

4)Login to controller datbase and send below query details.

Controller/bin/controller.sh  login-db

Mysql> select * from account \G;

Creator

Re: AppD is not getting installed properly

Hi
Thanks for replying.

Please find attached files as requested.
Also have a look at install command output.

 

Regards

 

 

Employee

Re: AppD is not getting installed properly

Installation has not completed successfully and there is no account created for the user, only system account is present in database. So please delete the complete controller directory and re-install the controller and see if it succeeds.

 

 

mysql> select * from account \G;
*************************** 1. row ***************************
                           id: 1
                  account_key: 10a4f4a2-5cfa-11e7-8039-005056863b50
                      version: 0
                         name: system
          global_account_name: system_10a4f4a2-5cfa-11e7-8039-005056863b50
                 display_name: system
               controller_url: NULL
       notification_config_id: NULL
saml_authentication_config_id: NULL
        ldap_configuration_id: NULL
       security_provider_type: INTERNAL
                   access_key: -001-24-mykoN6eQJKVvbtzwvq2lqw==45omhEZkWhLRZqbXnDcYog==
              expiration_date: 2145916800000
    coradiant_integration_url: NULL
coradiant_integration_enabled: 0
                      edition: ENTERPRISE
          start_date_of_trial: NULL
            end_date_of_trial: NULL
               original_email: NULL
          original_first_name: NULL
           original_last_name: NULL
        original_company_name: NULL
                    timestamp: 1
                      deleted: 0
             marked_for_purge: 0
             eum_account_name: NULL
        eum_cloud_license_key: NULL
        eum_event_service_key: NULL
    initialized_with_licenses: 0
     require_strong_passwords: 0
            encryption_scheme: scs
                   created_on: 1
1 row in set (0.00 sec)

.  

Creator

Re: AppD is not getting installed properly

Thanks Ravi.

I did it n number of times. I also tried on new Linux VM.
However facing same issue.

Main issue is it is taking almost an hour or more time at "Verifying controller ...." message.

 

Regards

Neelesh