Controller (SaaS, On Premise)

cancel
Showing results for 
Search instead for 
Did you mean: 

401 unauthorized in Rest Api

SOLVED
Highlighted

401 unauthorized in Rest Api

Hi Team,

 

I just created an appdynamics trial account and create a saas controller. when I call a GET to list applications it shows unauthorized 401 as response status.

 

i used postman as my rest-client

 

URL = https://baseball201801292052283.saas.appdynamics.com/controller/rest/applications?output=JSON

 

used basic authentication 

  username  = <username>@baseball201801292052283

  password = <password which is used for web login>

 

any solution?

 

Thanks

Ishara

 

401 unauthorized in Rest Api
6 REPLIES 6
Highlighted
AppDynamics Team

Re: 401 unauthorized in Rest Api

If its a SAML user we will not be able to hit the REST URL. Only LDAP and local AppDynamics user are allowed to hit the REST URL with required permissions. Please try to hit the URL with an existing local user (AppD user or create a local user) and let us know how it goes.

 

Thanks



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted

Re: 401 unauthorized in Rest Api

creating local user was the solution.

Thanks

Re: 401 unauthorized in Rest Api

Hi I have an example open source application that makes use of the rest UIs, check out https://chickenkatsu.co.uk/apps/reporter and  https://github.com/open768/appdynamics-reporter

 

 

Highlighted

Re: 401 unauthorized in Rest Api

Can you tell me how to create the local user in appdynamics? I am facing the same unauthorized problem in postman.

 

Thanks

Highlighted
AppDynamics Team

Re: 401 unauthorized in Rest Api

Hi Shruti,

 

Either you can use RBAC API to create a local user or you can navigate to setting symbol (top right side) -> Administration and create a user.

https://docs.appdynamics.com/display/PRO45/RBAC+API#RBACAPI-CreateUser

 

Note: To use the RBAC REST API, you must be the account owner or have administer user permission.

 

-Thanks



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted

Re: 401 unauthorized in Rest Api

Thanks. It worked.