cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

Business iQ (Analytics)

Internal buffers appear to be full - error (Analytics agent running fine)

Leanna.Yu
Voyager

Internal buffers appear to be full - error (Analytics agent running fine)

Hello,

 

I've seen other users have the same problem before so I followed their steps of making sure the Analytics agent was configured correctly and running, as well as the app server agent. But I still get the same error repeatedly in my logs. 

 

I had the Analytics running fine for a couple months until about a week ago, so I'm not sure what happened. 

 

Any idea how to fix this?

By replying you agree to the Terms and Conditions of the AppDynamics Community.
Internal buffers appear to be full - error (Analytics agent running fine)
4 REPLIES 4
Chitra.Lal
AppDynamics Team

Hello Leanna,

 

This error means that your app agent is not able to forward any events to the analytics agent(this can happen even if your agents are online, connected), so you might need to flush the queue in order to get this working. 

 

Please refer to the below article link for couple of ways how can we resolve this issue: 
 
 
Hope this helps. Do let me know in case you have questions. 
 
Thank You,
Chitra


Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Leanna.Yu
Voyager

Hi Chitra, 

 

Thanks for getting back to me.

 

Going through the link that you attached, I tried to perform the curl test and curl tells me that the connection is refused. So, then I made sure the config file for the Analytics agent was all correct, and restarted the agent through the command line to make sure any config file changes were taken into account for. The Analytics agent is reported as up and running but when I try the curl test again, the connection (to port 9091-- unless my analytics agent is running on another port for some reason?) is still refused. 

 

Do you know how to fix this? 

 

Thanks, 
Leanna

Leanna.Yu
Voyager

I also tried port 9090, a suggestion from another Discussion question, but connection was refused as well.
Mohammed.Rayan
AppDynamics Team

Do you see if the port is in listen state for the analytic-agent using the below command

netstat -an | grep 9090 (Unix)
netstat -an | findstr 9090 (Windows)

Can you also check in the analytic-agent.log to validate if its indeed up and running or it refused to startup due to an stale pid file


Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.